Jaguar I-Pace EV400 Forum banner

I got the TCU 19.2 update ...

  • Updated from TCU 17.2

    Votes: 0 0.0%
21 - 26 of 26 Posts

·
Premium Member
2020 Jaguar I-Pace HSE
Joined
·
135 Posts
I received a SOTA update to 19.2 last night. I've now got the latest vehicle connectivity system and the latest infotainment software update to S20C. I can't see the version for my battery energy control system; it's blank.
 

·
Registered
Joined
·
41 Posts
Off topic, but what were your symptoms causing them to replace the charge port? Mine was due to the locking pin not engaging.
For more detail see: Stuck initializing....
The short answer is that JLR replaced the charge port at 4000 miles for the locking pin not engaging. At 8000 miles the car would not charge, would be stuck at "Initializing". JLR determined an intermittent problem with the charge port or the cable assembly from the charge port to the batteries. The locking pin was engaging just fine on the second charge port so that was not the problem during the 8000 mile episode. As for the first problem at 4000 miles, the JLR told me the charge ports had a design flaw causing the locking pin problem and the charge ports were redesigned.
 

·
Premium Member
2020 I-Pace HSE Indus Silver
Joined
·
708 Posts
Sorry, I reversed my answer earlier. I got 20C OTA and the dealer installed 19C for me. In fact, the Service Advisor did not even know at the time that 19C was even out!
 

·
Registered
Joined
·
556 Posts
I used SOTA to get S20C last week, but still on TCU 16.2 since taking delivery of a 2020 HSE July 2019. Both times I've been to dealer I get "system does not show any updates for your car".
 
21 - 26 of 26 Posts
Top