Jaguar I-Pace EV400 Forum banner

201 - 211 of 211 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #201 (Edited)
@ardevd Great job with this app!
Question 1: Battery Health says 81%. What does this mean and is that a concern at all?
Question 2: Can we use this to see what veriosn software the car has to know if it is current?
Answer 1: There's a reason why the battery health setting is now disabled by default. After the H264 update the health value is way off. Don't pay attention to it for now. Hopefully it will be corrected by JLR in the future.

Answer 2: The API does report TCU versions but not in the same format as we've come to relate to.
 

·
Registered
Joined
·
65 Posts
Discussion Starter #202
Just upgraded to 1.3.4 and the estimated range is way off on the charging display but correct (agrees with Jaguar app and car) on the dashboard display.
Dashboard says 246 miles. Charging display says 397 miles (I wish). Switching to the charging display sometimes pops up saying it can't get current status but the dashboard doesn't have that problem.
Thanks for reporting this! I refactored the charging screen for 1.3.4 and I guess there was a miles/km bug that creeped in. I'll take care of it asap.
 

·
Registered
Joined
·
8 Posts
Answer 1: There's a reason why the battery health setting is now disabled by default. After the H264 update the health value is way off. Don't pay attention to it for now. Hopefully it will be corrected by JLR in the future.

Answe 2: The API does report TCU versions but not in the same format as we've come to relate to.
Awesome. What version TCU should we be looking for right now in the US to see if the car is current?

Again great job with the App!
 

·
Registered
Joined
·
65 Posts
Discussion Starter #204
Awesome. What version TCU should we be looking for right now in the US to see if the car is current?

Again great job with the App!
Unfortunately, I honestly have no idea. Without some community effort it's unlikely that we will be able to correlate what TCU versions the different API reported values correlate to.
 

·
Registered
Joined
·
448 Posts
Awesome. What version TCU should we be looking for right now in the US to see if the car is current?

Again great job with the App!
Many of us in US have TCU 18.2 version as reported in the car's SOTA display (where we can check for updates). If it is at a lower level, you may have to get it updated at a dealership but they don't usually update it without a reported problem. This is supposed to be SOTA updatable, but earlier versions may not have had that feature enabled.
 

·
Registered
Joined
·
36 Posts
Unfortunately, I honestly have no idea. Without some community effort it's unlikely that we will be able to correlate what TCU versions the different API reported values correlate to.
On the WattCat Vehicle Details page, find the TCU Software Version and decode the last 2 Characters as follows:

J8A2-70712-AY = 18.2

J8A2-70712-AX = 17.2

J8A2-70712-AV = 16.2

J8A2-70712-AT = 15.2

J8A2-70712-AS = 14.2

J8A2-70712-AR = 13.2

Cheers, Steve
 

·
Registered
Joined
·
65 Posts
Discussion Starter #207
On the WattCat Vehicle Details page, find the TCU Software Version and decode the last 2 Characters as follows:

J8A2-70712-AY = 18.2

J8A2-70712-AX = 17.2

J8A2-70712-AV = 16.2

J8A2-70712-AT = 15.2

J8A2-70712-AS = 14.2

J8A2-70712-AR = 13.2

Cheers, Steve
That's very useful! Interestingly enough mine shows up as AS. Looking back in my logs I can see that it's been AS since I got the vehicle even though I know I'm on at least 16.2. Wonder why the API does not reflect this. Maybe the API is only showing the version correlating with what the vehicle had when it was delivered.
 

·
Registered
Joined
·
448 Posts
That's very useful! Interestingly enough mine shows up as AS. Looking back in my logs I can see that it's been AS since I got the vehicle even though I know I'm on at least 16.2. Wonder why the API does not reflect this. Maybe the API is only showing the version correlating with what the vehicle had when it was delivered.
Likewise, my car reports itself as 18.2 on the software update display, but WattCat's info from API say "AR". It never changed from before when 18.2 was installed late last year. The TCU configure version never changed either.
 

·
Registered
Joined
·
544 Posts
Mine doesn't even display which telematics version it's using on the display. It just says No new updates. According to WattCat I have the "AS" version.
 
201 - 211 of 211 Posts
Top