Jaguar I-Pace EV400 Forum banner

1 - 20 of 22 Posts

·
Premium Member
Joined
·
133 Posts
So until Wattcat updated and has indicated that J8A2-70712-AX = 17.2 TCU Software Version, I always thought I was still on 14.2. Now the real question is since I am on 17.2 why does this not show in my car? It continues to have a blank in the space for the version.
 

·
Premium Member
Joined
·
133 Posts
Ok so I just read the most recent posts in the S20B thread and have found that a blank in my TCU version in the car is not so unusual. I guess I could claim this as a quirk in the car in another thread.
 

·
Registered
Joined
·
227 Posts
The version 14.2 does not report its version number in its API, so I guess Wattcat can't display that info ( I don't have any Android device to test) . Subsequent versions do. Here is a list of key/value that you can find in the 19.2 vs 14.2

Removed from the 14.2 list of keys:

  • ARM_REST_SECOND_ROW_INHIBITION
  • ARM_REST_SECOND_ROW_STATUS

Added to the list of keys, compared to 14.2

  • EV_CHARGE_TYPE
  • EV_IS_CHARGING
  • EV_IS_PLUGGED_IN
  • EV_IS_PRECONDITIONING
  • TU_STATUS_HW_VERSION
  • TU_STATUS_IMEI
  • TU_STATUS_SERIAL_NUMBER
  • TU_STATUS_SW_VERSION_CONFIG
  • TU_STATUS_SW_VERSION_MAIN
  • TU_STATUS_SW_VERSION_SECONDARY
 

·
Premium Member
Joined
·
133 Posts
Actually I am using an Android phone and thanks to Wattcat it is indicating I am on 17.2. My service technician slipped this one over on me 4 weeks ago when he updated to H264 and replaced my auxiliary battery. He never revealed this in the paperwork. My dealer is also a firm believer in not updating TCU unless absolutely necessary (meaning it would not be done just because you wanted it upgraded). Of course he only went as far as 17.2 and not the most recent TCU version.
 

·
Registered
Joined
·
101 Posts
The version 14.2 does not report its version number in its API, so I guess Wattcat can't display that info ( I don't have any Android device to test) . Subsequent versions do. Here is a list of key/value that you can find in the 19.2 vs 14.2

Removed from the 14.2 list of keys:

  • ARM_REST_SECOND_ROW_INHIBITION
  • ARM_REST_SECOND_ROW_STATUS

Added to the list of keys, compared to 14.2

  • EV_CHARGE_TYPE
  • EV_IS_CHARGING
  • EV_IS_PLUGGED_IN
  • EV_IS_PRECONDITIONING
  • TU_STATUS_HW_VERSION
  • TU_STATUS_IMEI
  • TU_STATUS_SERIAL_NUMBER
  • TU_STATUS_SW_VERSION_CONFIG
  • TU_STATUS_SW_VERSION_MAIN
  • TU_STATUS_SW_VERSION_SECONDARY
Pretty sure those API values you mention have always been there, also on TCU 14.2. I've worked with those values since before I got my car delivered back in early 2019.
 

·
Premium Member
19 I-pace HSE Polaris/Fuji white with most options and a lot of accessories
Joined
·
866 Posts
On 18.2 the first 4 in the list have the value "UNKNOWN". Do they get populated with 19.2?
The car is presently on a charger so 18.2 must not be supplying values.

The TU_STATUS_SW_VERSION... values seem to reflect what was originally installed in the car. The software versions never changed when my cat went from 14.2 to 18.2.
 

·
Registered
Joined
·
227 Posts
Pretty sure those API values you mention have always been there, also on TCU 14.2. I've worked with those values since before I got my car delivered back in early 2019.
I have created that list based on the list I received from a member on the forum (version 19.2), and my 14.2 version, so I am 100% that those keys are not returned by the 14.2 API version of car, at least from MY car :)
 

·
Registered
Joined
·
907 Posts
Discussion Starter #10
@ardevd I just got a message that my 12v battery is low and I should take it to the dealer.
Is that something accurate?
 

·
Registered
Joined
·
692 Posts
@ardevd I just got a message that my 12v battery is low and I should take it to the dealer.
Is that something accurate?
I received the same message multiple times although my message said to drive the car. I tested the battery with a multimeter and it was at 14.2V which is fine. If you're not getting a low battery warning in the car I think you're okay.

Edit: I just received the warning and the Details page shows the battery at 12.1V which is well below a 50% charge. Multimeter shows 14.2V.
 

·
Registered
Joined
·
907 Posts
Discussion Starter #12
I received the same message multiple times although my message said to drive the car. I tested the battery with a multimeter and it was at 14.2V which is fine. If you're not getting a low battery warning in the car I think you're okay.

Edit: I just received the warning and the Details page shows the battery at 12.1V which is well below a 50% charge. Multimeter shows 14.2V.
Good info, Thank you
 

·
Registered
Joined
·
101 Posts
I wonder why you're seeing that behavior. My car is reporting 12V battery voltage as expected. Are you guys on older TCU versions?
 

·
Premium Member
19 I-pace HSE Polaris/Fuji white with most options and a lot of accessories
Joined
·
866 Posts
Occasionally the data at the Jaguar servers are just crazy numbers. I've had it come back with extremely large and impossible odometer readings, a miles-to-service number that is 10K+ higher than the interval is, along with other insane numbers. I verified it wasn't a WattCat problem by using the other tools that use the API and the results were the same. It's just a momentary communication glitch of the bits going through the mobile network.

It sorts itself out after awhile.

As previously stated, I'm on 18.2 TCU software.
 

·
Registered
Joined
·
907 Posts
Discussion Starter #16
I'm on 18.2 TCU
 

·
Registered
Joined
·
907 Posts
Discussion Starter #19
What does the download mean? Patches to done to the car or available downloads?
Correct, it shows all update. Just scroll down and you can see the ones done
 
1 - 20 of 22 Posts
Top