Jaguar I-Pace EV400 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
147 Posts
Discussion Starter #1
On my forum posting "car seized up completely" it was mentioned JLR is recommending dealer replace the Telematics Module, but I logged into topix and I don't see any campaigns or recalls related to the telematics unit. It would be nice to know what the cause of all the software/hardware issues. It would also be nice to get the new infotainment software update that fixes creep mode. That's just such an annoyance having to turn it on EVERY TIME the car is restarted.



If a new module and software version would fix the issues with the car then it would be a good car to own. Right now my hardware/software issues are:

  • Backup Camera is very jittery and there is latency between what the camera shows and the actual position of the car. A few times the camera showed I had more distance to a wall and a car than I actually had. Good thing I was going very slow otherwise it would have resulted in an accident
  • Parallel self parking doesnt work. I tried it once (I will never try again). I was backing into a spot. The car did what it needed to; the steering wheel turned, the car backed into the spot but it didnt stop and if I didnt apply the brakes it would have hit the car behind me
  • Backup camera doesnt display in full screen mode. This often happens when I start the car and go in reverse
  • The seat cooler and heater display often doesnt display correctly. I can activate the seat climate control but it doesn't illuminate BLUE for cooling or RED for heating. You just see the little circle "checked" that the climate control is on but it doesnt display the color (see attached picture)
  • Tunein radio doesnt work. You can select Online media and you see the windows symbol just spinning then after 2 minutes it will time out. Then I have to go into sources, unselect tunein then reselect and then it works
  • The car constantly cycles the 3G/4G SIM card. It connect...then it will disconnect. Doesnt happen often but its a regular annoyance
  • Would be nice for the car to remember your driving mode (e.g. comfort, eco, sport)
  • Software responsiveness is slow. Motor trend had an a very good line saying a 10 year old iphone is faster
  • Center console reverts to a different setting. I selected my left screen to be drivers assist and right screen to be navigation but it reverts to an image of an I-Pace (and not even the color of my I-pace. At least tesla would display the color of the car)
  • I step on the brake, hit start. The car appears to start but I cant put in into gear. I have to hit the brake again and hit start again before I can put it into gear.
Now...here is just a simple request. Why doesnt the car auto-lock when you leave. My tesla did it. My 2019 Honda Civic can be programmed to auto lock. Why doesnt a luxury car with an avg price tag of $80k do it?
 

Attachments

·
Registered
Joined
·
199 Posts
I agree with your list of problems.
I have yet to figure out how to turn on just the seat cooling.:frown2:
Could just need more practice.
 

·
Registered
Joined
·
32 Posts
Agreed as well. When I first got the car, I nearly backed in to a retaining wall because I wasn't aware of the latency. Pretty lame.


I'll add that temperature settings on the climate control dials occasionally, magically, switch to Celsius. I'll get in the car, and they'll read '23' instead of '72'. Then, at some later point, they'll magically switch back to Fahrenheit.


Oh, and speaking of seat cooling - as far as I can tell, the cooler in the seat backs don't work. Or if they do, they're far weaker than the ones in the seat, um, seats. Using the parallel parking function is terrifying.
 

·
Super Moderator
Joined
·
2,289 Posts
Oh, and speaking of seat cooling
Brian's picture is what it looks like when you have the car in Eco mode. There's a little green dot in the middle. The whole seat does not get filled with blue as when you're not in Eco mode. It worked for me today.
 
1 - 4 of 4 Posts
Top