Jaguar I-Pace EV400 Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Good Morning,

This question is for my Canadian friends. What Sim card are you using? When I got my I Pace last November, I used the supplied AT&T card for three months, then pulled it out and put a Rogers card in. Worked perfectly from the moment I turned the car on and always had a connection. I recently switched to Bell. When I put the Sim card in, it would not connect, and would not even acknowledge the card. Jag put a new module in. Now the car will read the Sim, but will not connect. Is anyone here using a Bell or Telus sim card? I would hate to think I am paying $10 a month for two years and can't even use the service.
 

·
Registered
Joined
·
114 Posts
Sorry I can't help - I'm still using the AT&T card which I renewed at CDN$100 for twelve months. Works fine.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #3
Good price. If that had been available when I was trying to renew, I would have jumped on it. If I recall correctly, it was close to double when I looked at renewing the card.
 

·
Registered
Joined
·
260 Posts
Sorry I can't help - I'm still using the AT&T card which I renewed at CDN$100 for twelve months. Works fine.
When I tapped on the link to look at available plans, I got a page not found error, so I assumed there were no plans in Canada. I note that even with the "expired" SIM, traffic works, so it is unclear what yo actually get from the SIM other than the weather/news parts, web browser and in-car hot-spot?
 

·
Registered
Joined
·
38 Posts
I am using a Bell SIM card.
I have a data sharing plan amongst 4 phones, 2 tablets and the car’s sim.
Everything working perfectly fine.
 

·
Registered
Joined
·
56 Posts
I have a $10/month Rogers SIM that shares data with my plan.
The guys at Rogers told me to use the SIM in another device for a day before putting it in the car - which I did - and it's worked perfectly ever since.

Maybe take your Bell SIM card out of the car and put it in a phone for a few hours to make sure it connects to your wireless provider. If it does, try it in the car again.

Good luck!!
 

·
Registered
Joined
·
17 Posts
I'm using a Bell SIM card for tablet - works fine.

I just wish that I Jaguar would add the Deezer option to the media source so that I could stream music without using my phone. Seems this only works in USA and UK at this point.
 

·
Registered
Joined
·
801 Posts
I'm using a Bell SIM card for tablet - works fine.

I just wish that I Jaguar would add the Deezer option to the media source so that I could stream music without using my phone. Seems this only works in USA and UK at this point.
Isn't deezer part of the Online Media source?
 

·
Registered
Joined
·
25 Posts
When I tapped on the link to look at available plans, I got a page not found error, so I assumed there were no plans in Canada. I note that even with the "expired" SIM, traffic works, so it is unclear what yo actually get from the SIM other than the weather/news parts, web browser and in-car hot-spot?
My question as well! All that I seem to want from it is traffic, which, like you, I am still getting after many months.
 

·
Registered
Joined
·
17 Posts
Isn't deezer part of the Online Media source?
Yes but it still is not active in many countries - only works in USA and UK, from what I can surmise looking in the UK Ipace forum. For Canadian vehicles, when pressing on the Source icon, there is no option for Online Media Source.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #12
Thanks for the answers. My car is at the dealer right now getting the H264 update, and they are looking at the Sim card issue now. Hopefully they can get it figured out.
 

·
Registered
Joined
·
9 Posts
I have a $10/month Rogers SIM that shares data with my plan.
The guys at Rogers told me to use the SIM in another device for a day before putting it in the car - which I did - and it's worked perfectly ever since.

Maybe take your Bell SIM card out of the car and put it in a phone for a few hours to make sure it connects to your wireless provider. If it does, try it in the car again.

Good luck!!
Interesting option to check out. The Tablet SIM I got from Rogers never connected, I didn't try out this technique suggested.
 

·
Registered
Joined
·
115 Posts
I have a Roger's sim that came from the dealer - Budds in Oakville. Seems to be good for the duration of the lease. I wasn't given any details about the plan - didn't think to ask when I got the car. Also not a line item in the lease that I can see. I assume the cost is built in somewhere.
 

·
Registered
Joined
·
260 Posts
I have a Roger's sim that came from the dealer - Budds in Oakville. Seems to be good for the duration of the lease. I wasn't given any details about the plan - didn't think to ask when I got the car. Also not a line item in the lease that I can see. I assume the cost is built in somewhere.
Are you getting full service (weather, news and hot spot), or traffic only? I have no plan that I know of (Montreal) but still have traffic updates.
 

·
Registered
Joined
·
115 Posts
I have a Roger's sim that came from the dealer - Budds in Oakville. Seems to be good for the duration of the lease. I wasn't given any details about the plan - didn't think to ask when I got the car. Also not a line item in the lease that I can see. I assume the cost is built in somewhere.
Are you getting full service (weather, news and hot spot), or traffic only? I have no plan that I know of (Montreal) but still have traffic updates.
Traffic, internet browser. Hot spot. Didnt try news and weather specifically but should work as general internet works.
 
1 - 16 of 16 Posts
Top