Jaguar I-Pace EV400 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter #1
Hello all. I just bought an I-Pace HSE. I've had it a few days, and am happy with my purchase. I've had 2 BMW i3's, so have been at electric cars now for a few years. I live in Iowa...so far I'm the only I-Pace in the Des Moines metro area. The only downside to date is getting a slow DC charge rate of 40kW, but I'm hoping this gets ironed out by a software update. Overall, I think the car is awesome, and at a luxury and fit-and-finish level above what I've seen in other electric offerings.
 

·
Super Moderator
Joined
·
1,927 Posts
Welcome. I saw your other post on charging rate. Do yourself a favor and spend some quality time reading relevant discussions on this forum, you'll learn a lot. Charging rate depends on SoC, so you were probably charging with a fairly full battery. Can you charge at home? Again, there's a lot to learn. Take the time to do so and you will avoid some of the more common frustrations, and have appropriate expectations.
 

·
Registered
Joined
·
82 Posts
Discussion Starter #3
Thanks for your reply, sciencegeek. Yes, looking forward to doing some reading here. I do have a Level 2 charger at home, so I'm good there. We were trying out the level 3 Electrify America charger near our home because we'll be doing some longer trips in the I-Pace this summer...just wanted to see how it worked and what the charge time would be. Our first trip we had 60% SOC and pulled just under 50kW. Our second try we were at 30% SOC and got only 40kW. After reading the replies on the thread about it, post my question, surely this is a software issue. I scheduled an appointment next week, so I'll see then.
 

·
Registered
Joined
·
562 Posts
I would call EA first before taking the vehicle in. I doubt there is a software issue.
Most likely a cool battery and the software may limit charge.
Still a bit chilly in Des Moines yes? I was just out there last week to look at Iowa State.
 

·
Super Moderator
Joined
·
1,927 Posts
Thanks for your reply, sciencegeek. Yes, looking forward to doing some reading here. I do have a Level 2 charger at home, so I'm good there. We were trying out the level 3 Electrify America charger near our home because we'll be doing some longer trips in the I-Pace this summer...just wanted to see how it worked and what the charge time would be. Our first trip we had 60% SOC and pulled just under 50kW. Our second try we were at 30% SOC and got only 40kW. After reading the replies on the thread about it, post my question, surely this is a software issue. I scheduled an appointment next week, so I'll see then.
Great! I agree with Time2Roll, check with EA if there's some idiosyncrasy with that charger. But certainly 40kW at 30% is not ok.

In all likelihood you'll have ChargePoint and EVgo chargers near you. Those are great. They give you real-time availability and the charger specs. Check the PlugShare app too.

Here's a thread on charging rates with my home charger, which should be very similar to yours if you have a standard 240V/32amp circuit.

https://www.i-paceforum.com/forum/554-2018-i-pace-ev-batteries-charging/2695-charge-curve-below-0%.html
 

·
Super Moderator
Joined
·
1,927 Posts
P.s.: Here's another chart, which shows a few charging sessions and how GoM Range prediction and SoC change as a function of charge added by a 240/32 charger.
 

Attachments

1 - 6 of 6 Posts
Top