Jaguar I-Pace EV400 Forum banner

21 - 26 of 26 Posts

·
Registered
Joined
·
608 Posts
Woohoo, glad the battery is okay. I heard many crazy theories from the dealer so I started texting my salesman to give them correct information for potential new buyers.
 

·
Registered
Joined
·
608 Posts
Great. You've already found out that you know more about the I-Pace than the dealer. It frightened me that older customers or those who aren't tech savvy were getting bad information. I found this forum by shear chance and I'm grateful I did.
 

·
Registered
Joined
·
568 Posts
So the story I got from Jaguar that car is limiting charge rate if under 1000 miles seems to be made up :) and unbalanced battery was the limiting factor.
I think both could be correct. A vehicle with low miles very few charging sessions could be prone to having some unbalanced cells. Dealer will always white wash these issues or customers with little understanding could become overly concerned. And of course the dealer has zero people from the JLR engineering team. So maybe just relating previous customer experience and giving assurance all is OK.
 

·
Registered
Joined
·
260 Posts
You are correct that this is a great forum. I have had my car for about a year (I need to look it up to not miss the birthday) and the forum has added to the great experience I’ve had with the car so far!
 

·
Premium Member
Joined
·
168 Posts
Here's another data point showing charge rate starting at 50%. This morning I hit a 125kWh-capable Chargepoint DC fast-charger since I was low on range for a long drive today. I started the DC charge at 50% and stopped it at 93%, gaining 35kWh (43%) in 38 minutes. The charge initially peaked near 81kW and fairly linearly dropped to 36kW where it appeared to flatten out before I unplugged.
3926
 
21 - 26 of 26 Posts
Top