Jaguar I-Pace EV400 Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
Has anyone updated their Navigation/ Map. I kept getting a pop up on my navigation saying update your map. So I followed the instruction and downloaded it to a USB from my computer and then try to put it on the car but the car would not do anything I did not recognize the USB with a map update. Has anyone else done this or is there a solution around this.
 

·
Registered
Joined
·
33 Posts
Hi Abs2780,
Yes I did the update a few times and it worked without problems.
I started on the InControl website
https://www.jaguar.com/incontrol-global/incontrol-user-guide/incontrol-map-updates.html
Selected Download Map Updates under the most left "Touch Pro and Touch Pro Duo" heading.
That gets me to the jaguar.here.com site and I have to sign in again.
On the bottom right I select Go to Maps & Services
For me I select the North American Maps + Services (3 y subscription)
Version Number: 08.030.0100.0153
Click "Get Latest Version"
Click Download Map
It opens a box asking me to open the Map Downloader tool
The Download Tool opens and I plug in a USB stick with at least 10Gb of space (I am using a SanDisk Ultra USB 3.0 32Gb stick)
After the download is done I just take the USB stick to the car, turn on the car and wait for the navigation system to load.
Then plug it into one of the two USB ports under the central arm rest. The car recognizes the map update and on the main screen it asks me to install and after about 10 minutes the update is done.

A few things that may be going wrong that I can think of:
- You didn't select the Touch Pro Duo version?
- You are using a USB stick that is somehow not being recognized (cheap generic?)

Best,
Wouter
 

·
Registered
Joined
·
485 Posts
10 minutes? It pops up and says it'll take about 30 minutes. In reality for me it is closer to 50 minutes.
 

·
Registered
Joined
·
33 Posts
10 minutes? It pops up and says it'll take about 30 minutes. In reality for me it is closer to 50 minutes.
For me it is considerably faster than 30 minutes. It takes me 15 minutes to drive to work and it is done before I get there.
Perhaps because I am using USB 3.0?
 

·
Registered
Joined
·
31 Posts
Hi Abs2780,
Yes I did the update a few times and it worked without problems.
I started on the InControl website
https://www.jaguar.com/incontrol-global/incontrol-user-guide/incontrol-map-updates.html
Selected Download Map Updates under the most left "Touch Pro and Touch Pro Duo" heading.
That gets me to the jaguar.here.com site and I have to sign in again.
On the bottom right I select Go to Maps & Services
For me I select the North American Maps + Services (3 y subscription)
Version Number: 08.030.0100.0153
Click "Get Latest Version"
Click Download Map
It opens a box asking me to open the Map Downloader tool
The Download Tool opens and I plug in a USB stick with at least 10Gb of space (I am using a SanDisk Ultra USB 3.0 32Gb stick)
After the download is done I just take the USB stick to the car, turn on the car and wait for the navigation system to load.
Then plug it into one of the two USB ports under the central arm rest. The car recognizes the map update and on the main screen it asks me to install and after about 10 minutes the update is done.

A few things that may be going wrong that I can think of:
- You didn't select the Touch Pro Duo version?
- You are using a USB stick that is somehow not being recognized (cheap generic?)

Best,
Wouter



I vaguely remember having a problem with a map update some time ago, related to the formatting of the USB stick. It may - please check, as I can't find any reference to this in the 'official' documentation at the moment - need to be in FAT32 format prior to downloading the map update. Many (most?) new USB memory sticks will be pre-formatted - or Windows will default to re-formatting - in NTFS (or NT File System).
 

·
Registered
Joined
·
142 Posts
I vaguely remember having a problem with a map update some time ago, related to the formatting of the USB stick. It may - please check, as I can't find any reference to this in the 'official' documentation at the moment - need to be in FAT32 format prior to downloading the map update. Many (most?) new USB memory sticks will be pre-formatted - or Windows will default to re-formatting - in NTFS (or NT File System).
Agree this is likely the problem preventing the car from recognizing the USB stick. I verified mine is FAT32 and it works fine. I'm surprised the instructions don't call this out! (I just checked)

I also update fairly quickly, somewhere in the 10 minute range despite the original estimate of 30 minutes. Mine is a USB 3.0 stick. USB 2.0 sticks will be substantially slower. The 30 minute estimate is probably presented for those using a USB 2.0 drive.
 

·
Registered
Joined
·
33 Posts
I vaguely remember having a problem with a map update some time ago, related to the formatting of the USB stick. It may - please check, as I can't find any reference to this in the 'official' documentation at the moment - need to be in FAT32 format prior to downloading the map update. Many (most?) new USB memory sticks will be pre-formatted - or Windows will default to re-formatting - in NTFS (or NT File System).
Yes the Download Tool explicitly asks for a USB stick in FAT32 format.
(I would presume the tool would check for the proper formatting of the USB stick and would warn you if it is not FAT32 but maybe it doesn't)
 

·
Registered
Joined
·
485 Posts
I'm definitely using USB 3.0. I'll try a different one with the next update (next week). It could be quality of the stick (how it internally works) that slows it down. It's a Microcenter branded (i.e. inexpensive) stick.
 

·
Registered
Joined
·
3 Posts
Has anyone noticed that our navigation maps show GAS stations but not charging stations??
Hope JLR will fix that up soon. It’s seems that all the apps for charging stations don’t cross reference with each other well
 

·
Super Moderator
Joined
·
1,158 Posts
Has anyone noticed that our navigation maps show GAS stations but not charging stations??
Hope JLR will fix that up soon. It’s seems that all the apps for charging stations don’t cross reference with each other well
the JLR nav does indeed show charging stations. Go into your settings and turn that feature on if it isn't currently displaying for you.
 

·
Registered
Joined
·
2 Posts
I couldn’t be more disappointed in the navigation system in my first edition. I just finished running the update which by the way is completely absurd for users like us to jump through all of those hoops to get the update and install it. We have over the air updates why isn’t this done using that system.

I went into the settings to select the connector to use to filter charge stations. There is no level III charger listed Although they did list a level two charger with the correct graphic for the level III charger.

I set up a navigation that needed a charge during the trip and after 10 minutes of a spinning icon they never listed the charge stations.

I’m in the US not Europe for your information and I’m really disappointed
 

·
Super Moderator
Joined
·
1,158 Posts
It is definitely not intuitive or user friendly. It also is not as comprehensive or accurate as PlugShare. But if you go into the submenu of the submenu in the nav setting you have a plethora of ill-defined options to select/de-select for display. By playing with the multitude of options, you will probably stumble upon one that will work OK.

There have been a couple threads on the issue. This is one I found doing a quick search of the forum.

https://www.i-paceforum.com/forum/193-2018-jaguar-i-pace-ev-400-general-discussion/2737-nav-wont-find-ccs-chargers-what-am-i-doing-wrong-2.html
 

·
Registered
Joined
·
84 Posts
On a related note and sorry if this has been covered elsewhere but if the nav selects a route and during the trip traffic conditions change, will it reroute? My Tesla did and you could set the threshold of how much time savings to reroute for. Wondering if the I-pace also reroutes.
 

·
Registered
Joined
·
485 Posts
It calculates a new route. This can make you wonder why since it isn't human and it doesn't explain why (like my ex).

Additionally, when the battery gets low and it thinks you need to charge the car to get there, it will prompt with routing to a nearby charger (that it knows about and ask for confirmation to take that route, or you can decline. I've had it offer to route to a charger behind me (i.e. go back to a charger) because it thinks I won't have enough charge to get to the destination (which happened to be a charger it didn't know about).
 

·
Registered
Joined
·
25 Posts
Discussion Starter #15
So thank you for the detail update on how to properly update my navigation. It worked, it was fairly easy. Again thank you.
 

·
Registered
Joined
·
63 Posts
"media not supported for multimedia format"

used the creation tool to format and download.

anyone else get this?
 

·
Registered
Joined
·
485 Posts
FWIW. You need a 32GB (not anything bigger) 3.0 or 3.1 USB. I've used Samsung and Verbatim brands for the Dec and Jan updates. They've proven to provided the expected speed during the updates.
 

·
Registered
Joined
·
689 Posts
FWIW. You need a 32GB (not anything bigger) 3.0 or 3.1 USB. I've used Samsung and Verbatim brands for the Dec and Jan updates. They've proven to provided the expected speed during the updates.
I've learned the hardway that 3.1 does not work in the I-Pace

I have a 64gb but has to format as Fat32 for it to work to play media.
 
1 - 20 of 26 Posts
Top