Jaguar I-Pace EV400 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
Well after my seized car with apparent 12v battery was fixed. The car drove fine for a few weeks with small problems.... Over the weekend we went to a friend‘s place 50 miles away. Due to COVID only 5 close knit known families got together. Late in the night when we were all leaving,the Jag wouldn’t start. After 3 or four tries it started and we drove home. As I started, the range said 173mile, after about 30 miles into the journey the range dropped to 53 miles! However drove home another 20 miles and the range was was 43 miles. Yesterday the starting issue came up again. Started after 3 to 4 attempt.
At this time it is serious anxiety driving the car.

Anybody had a similar issue and any solution. Please help. I will take it to the dealership in next couple of days after the winter storm blow over in NJ.
 

·
Premium Member
19 I-pace HSE Polaris/Fuji white with most options and a lot of accessories
Joined
·
1,249 Posts
Open the front. There are 2 plastic retainers that require Phillips screwdriver.
Back out the screw parts until the retainers can be pulled out.
Lift out the panel they retained.
On the passenger side of the vehicle is a large automotive battery.
Validate that the cables are properly tightened to the posts.

On the opposite side, is a smaller battery. Locate it with the the red cap that is over its positive post. Verify the cables are secured tight to their posts.

Reassemble.

If you found anything loose, connect the car for charging.
If you didn't find anything loose, then the dealer will have to find the fault, possibly the BCCM is defective, or a loose ground somewhere else.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #3 ·
All connectors are tight. The battery was replaced last time when the car seized.. now guess it needs to go back to the dealer for diagnosis.
Thanks for your prompt response.
 
1 - 3 of 3 Posts
Top