Jaguar I-Pace EV400 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
392 Posts
Discussion Starter #1
The night before both touchscreens failed, and 24 hours after picking my car up from the dealer, I posted that the car was working great but I probably just jinxed myself and sure enough, I did! Friday afternoon I picked up my car from the service department after another week of troubleshooting and repair. The dealer installed a software "patch" (software version is not on my paperwork) in the telematics server and both touchscreens are again functioning. Reading the paperwork, it is clear that it took multiple attempts to get the car to communicate with the Jaguar TCU and the dealer also needed multiple tries to get a call through to Jaguar roadside assistance from the call button in the overhead console.
I took the car for a long drive last night and I observed that the infotainment system that was updated to 19A boots faster, various screens manage faster and the voice command is still lagging but understands navigation commands very well. I didn't try media or other commands yet but will do so this evening. I am 2 for 2 in getting the car to set a departure from the InControl app but haven't tried timed charging as I use my ChargePoint app but that will be my next experiment. I think the trip bank kWh/100 mile reading is more accurate as is the range prediction. This is a little disappointing as the numbers have increased while range prediction has decreased but at least I can trust the system better than from before the upgrade.

SOTA is now available as are new maps for the nav but I am not going to change anything as I don't want to introduce new problems. I'll keep the forum informed if problems occur.
 

·
Registered
Joined
·
209 Posts
@CurtSprings What did you mean by "SOTA is now available"? Does it show a software update is available to download and install when you search for updates through your infotainment screen?
 
1 - 4 of 4 Posts
Top