Jaguar I-Pace EV400 Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello ... I purchased a 2018 I-Pace with the HSE trim. I wanted the highest performing audio system but the sound quality while playing music through Bluetooth is dull and disappointing. The same phone and the same song sounds much better on my base model Kia Telluride. I turned on my phone's developer options and determined that the I-Pace's infotainment system is using the SBC codec but my Kia is using AAC which is far superior. This article suggests that the I-Pace should support AAC:


Any tips on improving sound quality? Or perhaps how to get AAC working?

Thanks!!
 

·
Registered
2020 I-PACE SE w/ 22" F-PACE Wheels
Joined
·
237 Posts
I find the 825w Meridien system in my 2020 to be completely underwhelming, regardless of source. The mids are very lacking, and it feels closer to a 25w system than 825w.

Interestingly, we previously had a 2017 Jag XE with the "same" 825w system. It was light years better. Which makes zero sense; if anything the acoustics of a hathback/SUV like the I-PACE should provide better sound. I keep wondering if something is wrong with my system, but the dealership doesn't have any I-PACEs for me to compare it to.

Good tip on AAC though. Will give it a go. Note that you have to be connected to the vehicle to modify the setting in developer options.
 

·
Registered
Joined
·
1,684 Posts
I find the Meridian system to have nice, flat response and low distortion as car stereos go. It could have more low bass, sure, but that's almost always the case. It doesn't distort much as the volume increases. It's a good stereo.
 
  • Like
Reactions: bitzerj and JDH

·
Registered
Joined
·
731 Posts
If you want highest quality, don't use bluetooth. Use a high quality source via the USB port. I use a 128MB drive filled with CD's converted to FLAC. They sound fantastic!
I agree that the I pace sound system is underwhelming. But I was coming from a 2011 so for me it was dramatically better than what I had before.

I would second that the easiest fix for your problem is to simply plug it in. This isn’t ideal and you shouldn’t have to, but I don’t know of any other solution.
 

·
Premium Member
19 I-pace HSE Polaris/Fuji white with most options and a lot of accessories
Joined
·
1,938 Posts
Have you validated that it is set to the Meridian mode, or other mode of your choice? Check the settings.

Here's from a 2019. Pick "Stereo", "Meridian", "Dolby" or "dts" along the bottom of the "AUDIO SETTINGS" display. You get to it from within the media display by touching the gears icon (as shown below "Dolby"), then "Audio settings".
Product Font Line Red Material property
 
1 - 7 of 7 Posts
Top