Jaguar I-Pace EV400 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I have noticed that the blind spot monitor do not work as described. It only give me a warning when a car in the lane beside is at my rear wheel. That’s a bit late.....
Luck I am old school and look over shoulder.
It is supposed to react much earlier. Like 23 feet from rear bumper if I read the manual right

Other brands have had very good blind spot detectors. With reasonably early warning.

Anyone else seeing the same issue?
For me it is on both sides.
Either a system issue or both sensors bad. Or maybe software.....

It will go into service again soon to have this checked. As soon the mechanic is back. I have a dealer that allow me to talk directly with the mechanic. This have speeded up a lot of diagnostics for unusual faults.
Engineer to engineer talk works much better ?

Apart from all the still existing software bugs I still love the car but it have started to get irritating with all this things Jaguar never seem to be able to fix.
Black screen and self rebooting while driving navigation as examples.
 

·
Registered
Joined
·
392 Posts
I've noticed the same issue and brought the car in for service. The technician stated that everything was working as designed but I still have the problem - to the point where I don't use it anymore. I'm thinking about filing a complaint with the NHTSA because of the accident risk. I also plan to complain about the adaptive cruise control that locks on to vehicles not in my lane. Occasionally the cruise control will apply the brakes with no one in front of me.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
What a comment. “ Work as designed”. Then it should match the owner manual description.
That’s just an excuse to not check it.


If me and my mechanic find the solution I will tell.
If not I agree it should be filed as a safety related issue.

I have luck as my cruise seem to behave as one can expect.
Only one time it tracked a car that changed to other lane and stopped there. Left turn lane. As he was on the white line still it was probably correct that system brakes as the other car did occupy a small piece of my lane.
 
1 - 4 of 4 Posts
Top