Jaguar I-Pace EV400 Forum banner

Android Auto not working

8030 Views 8 Replies 6 Participants Last post by  requieh
Anyone else having trouble getting Android Auto to load? I have a Samsung Galaxy S10 and at first thought maybe it was the phone because some other S10 owners had Android Auto issues in general, but I was just in an Audi A4 rental for a few days and Android Auto worked seamlessly. When I plug in my phone into either of the main 2 ports in the center storage bin nothing happens. I've even tried changing the USB settings on the phone to try every other option...File Transfer, Media, etc but it never boots up on the screen or gives me the Android Auto Icon in the car. I tried going into the Android Auto settings in the car but it tells me I need to connect a compatible device first before it will let me into any settings. It used to work when I had my Galaxy S10 so I just can't figure out if there's something not playing nice with my S10 and the I-Pace.
1 - 9 of 9 Posts
When you connect the cable it should give you a choice of launching the device with AA or not. Do you get that choice?
If not, try deleting the device from the car's bluetooth settings and try again.
I would try repairing your S10, but everything should be automatic with the phone plugged in. Compatibility for specific devices can vary, but I doubt that's the issue with a newer Galaxy.
Cables are the #1 issue with cellphone connectivity with cars.
Remember only 2 ports are CarPlay/AA compatible, those two in the center armrest.
#2 issue is privacy/power settings in the cellphone are stopping it.
#3 is the operating system quirks of various brands.
#4 is the automaker. Why? It costs them millions in service visits if your cellphone won't connect, even if there is nothing wrong with the car. Chevrolet went through this with CarPlay. It was an Apple OS update that fixed the problem, not a reflash of the GM car.
Tried all of the following with no luck. The fact that it works perfectly in other cars is why I think something is not playing nice with the I-Pace and my phone.

1) Deleted my device from the car's bluetooth settings and deleted IPace from my phone connection, then set it all up again
2) Restarted my phone
3) Tried 2 different cables...both of these cables with in other cars with Android Auto
4) Tried turning off all power mgmt settings

When I plug in the phone cable, my phone starts charging right away but I dont get any Android Auto pop up or options on the car screen or my phone screen. I've also tried changing the USB connection option in the dropdown notifications in my phone...tried File Transfer, MIDI, etc. When I try each one then tap on Android Auto on the I-Pace screen, it either tells me the device connection isn't compatible or it give me a pop up screen telling me to connect a device using the 2 middle USB ports (even though my device is already connected)

Still no luck, but thanks for the suggestions. CarPlay works fine with an iPhone though, go figure.
See less See more
Hi @billfan

First few questions (apologise they may seem stupid) .
1. what level of the Touch Pro software is installed in your vehicle (Settings>All settings> Software update)? Should be 18C of higher.
2. I am assuming, that on your infotainment's Extra Features page (on the right from the Home Page) among features like 'Eco', Valet mode', you can see Android Auto and CarPlay listed. If not, your vehicle is not fitted with them....
3. If you connect USB stick with the media (music, video, etc) on it, can you play it via infotainment?
4. When you are connecting phone to the USB sockets in the armrest compartment, is the phone starting to charge?

If all of the above are OK, then look at the below hints:
- first try use different phone AND different cable. Best non-samsung one. If the issue repeats, then look below. You can also check some iPhone to see it CarPlay starts (this is to prove, that your infotainment is working OK with other devices)

- second hint would be to use different USB cable with your S10 (and different android phone if possible) -> change the cable to the one which is NOT USB 3.0 compliant (the wider USB connector which goes to your vehicle's USB sockets MUST NOT be with blue insert inside).

There was an issue visible with some Samsung phones and some older version of the Touch Pro Duo software (18C, probably also 18D), where they were not supporting correctly Android Auto protocol over USB-3. Note, that your I-Pace has USB-3 sockets. To make it working, all of the elements in the communication chain must support it correctly.

So once you will use USB cable with USB-A to USB-C connectors, but which support USB 2.0 data transfer speed, you are forcing the devices to use USB 2.0 protocol, and AA should start to work.

- third - if above solutions wont help, then you would need to visit a Jaguar dealer, complaining that Android Auto is not working and asking for the update to the latest software. What is good, update may be quite fluent now, as dealers are recently equipped with the solution, to push new software to your vehicle over-the-air.

Please let me know how it progressed.
See less See more
Update: My phone got an Android Update yesterday (March security patch) that included other fixes from Samsung and right after that update, Android Auto started working perfectly in the I-Pace so it must have been something in the software. I'm on T-Mobile so FWIW the baseband version I'm on now is: G973USQU1ASD3. Specifically, the updates bring the March 1, 2019 Android security patches as well as stability improvements, bug fixes, performance improvements, and unspecified “new and/or enhanced features” so somewhere in there it fixed Android Auto. Woot!
  • Like
Reactions: 2
Anybody else have a problem with WAZE in Android auto of frequently "locking/freezing" your position and not updating the map as you move? I've regularly had to "Ok Google, Navigate To" and swap to maps while moving.
@WattAJag - yes, I've spotted it recently, that WAZE is not working as fluent as before... Google must had messed something once they have update AA app...
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.