Jaguar I-Pace EV400 Forum - View Profile: zdehwanz

zdehwanz zdehwanz is offline

Junior Member

  Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. zdehwanz
    03-13-2019 07:52 PM - permalink
    zdehwanz
    Just got a brand hew I-Pace HSE. On day two, it gave me a brake fault alert, then brake pedal feel adjustment alert and then it shut down. Every time I turn it on, it gives me a "ASPC not available", "Gearbox Fault Alert", "Emergency Brake Assist not available, OK to drive with caution" and "Traction battery fault detected, OK to drive with caution" fault and then the vehicle powers down within seconds. Called Jag roadside assist and they sent tow truck, they could not figure out how to tow the car. It would not go to neutral, the "P" for Park was flushing the whole time. Dealership has not been able to send a mechanic. The car is parked in my driveway now for 4 days and dealership (Sacramento Jaguar) is not even returning my phone calls. What options do I have as a consumer? I am trying to reach out to the management and even to corporate office. I feel like I might have been dealt a lemon!

  Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 09-24-2019 02:47 PM
  • Join Date: 03-13-2019
  • Referrals: 0

  Mentions

No results to display...

  Quotes

09-24-2019
11:13 PM - fedorachef quoted zdehwanz in post Jag Remote app (Android issue)
How do you clear cache in dat...

Search Tags for this Page

Jaguar I-Pace Forum

,
Jaguar
,
IPace Forum
,
I-Pace Forum
,
I-Pace
,
IPace
 
For the best viewing experience please update your browser to Google Chrome