New Car Cgarging - Jaguar I-Pace EV400 Forum
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 06-01-2019, 07:21 AM Thread Starter
Junior Member
 
Join Date: Jun 2019
Posts: 1
New Car Cgarging

Hello all

we have just picked up the I-Pace and very pleased to own one.

We used to have a BMW I3 and have a Rolec Wallpod installed at home.
Came to charge the new car today and it will not register with the supplied Jaguar cable but it works with the Rolec cable ?

I am worried that the charger may not be compatible and that we may do damage to the car ...could this be a faulty Jag cable or another issue ?

As this is the first time we have charged it ...is it normal for the car to make a noise when beginning to charge ?
Thanks
Adrianb10 is offline  
post #2 of 4 (permalink) Old 06-01-2019, 08:33 AM
Senior Member
 
Join Date: Oct 2018
Posts: 648
It will not harm your car, all EVSE L2 are compatible and negotiate/signal with the car charging circuits. The main difference is maximum charge rate, and the i3 charger should be able to supply 6 or 7 KW charging for the I Pace. The I Pace maximum L2 charge rate is 7 KW.

Are you in Europe where the charge cable attaches to the EVSE?
epirali is online now  
post #3 of 4 (permalink) Old 06-01-2019, 12:19 PM
Senior Member
 
Join Date: Sep 2018
Location: So Calif
Posts: 362
The wall unit is just a safety relay. The electricity to power the vehicle on board charger is just passing through from your house to the car.
All the wall units are built to the same J1772 specification.
Time2Roll is online now  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 06-01-2019, 12:23 PM
Senior Member
 
Join Date: Jun 2018
Location: Castro Valley, CA
Posts: 613
Yes, the car makes noise when it charges. You may have a bad jaguar cable.

Photon FE, 2013 FR-S, 2017 RAM 1500, 2014 Forester
jsimon7777 is online now  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome