Irritated w/Infotainment, etc - Jaguar I-Pace EV400 Forum
 24Likes
Reply
 
LinkBack Thread Tools
post #1 of 58 (permalink) Old 02-02-2019, 09:35 PM Thread Starter
Senior Member
 
Join Date: Dec 2018
Posts: 375
Irritated w/Infotainment, etc

Just need to vent to my fellow I-Pace owners...

I like the car quite a bit but I'm definitely second guessing my purchase at the moment.

Navigation through the car is horrible. I've been using Car Play more now, but even that today took forever to launch, then crashed the stereo and native map screen on the gauge cluster. Then Car Play became non-responsive - even after I unplugged the whole system was a mess.

The load times are obnoxious on this car. I would take slightly more battery use when parked for a system that was ready to go when I hopped in.

Why we don't have wireless Car Play is also beyond me.

The next irritation is probably my own fault - the 22" wheels... They look great... They're pretty rough on the road though..

As I've said before, I'm coming from a '16 X5 Diesel. In that I only had to fill up every ~400 miles or. In the I-Pace, with 500 miles on it, I've had to charge 3-4 times as I knew even with 50% left, I would most likely need more due to the loss of charge in the colder weather. While this just means plugging in at home, I actually think the cost to "fuel" the I-Pace might be MORE than my diesel X5...

In fact, while the I-Pace and the X5 are priced similarly, I think the ride and refinement is more on par with an X3 the more I think about it...

I chose the I-Pace because I wanted something environmentally friendly, fun and comfortable. The infotainment system is crushing my experience with the car and making me focus on all the other small items - like the slightly rough ride.

/end rant (for now).
sgtpeper is online now  
post #2 of 58 (permalink) Old 02-02-2019, 09:58 PM
Senior Member
 
sciencegeek's Avatar
 
Join Date: Jun 2018
Location: Palo Alto
Posts: 1,115
Ah man I feel for you. If your CarPlay worked and your tires were more forgiving you would be so stoked!
sciencegeek is online now  
post #3 of 58 (permalink) Old 02-02-2019, 09:59 PM Thread Starter
Senior Member
 
Join Date: Dec 2018
Posts: 375
Yea, it's just the overall experience with the infotainment. I've never had a system take this long to load and fail this often. I'm on D for the upgrade by the way.
sgtpeper is online now  
Sponsored Links
Advertisement
 
post #4 of 58 (permalink) Old 02-02-2019, 11:48 PM
Senior Member
 
Join Date: Oct 2018
Posts: 765
Worst case cant you order the 20 wheels with tires and swap out? Maybe even try selling the 22s or swap with someone who wants them?

Hopefully the infotainment system will improve with software updates.
epirali is online now  
post #5 of 58 (permalink) Old 02-03-2019, 12:31 AM
Senior Member
 
PGhiron's Avatar
 
Join Date: Nov 2018
Location: Westchester, New York
Posts: 144
Interesting enough I decided today to put the car on the highest ride setting (you know the one for off road), and the ride smoothed out a lot. After more than 2 months I had never tried that before. I was really surprised. Try it and see what other think.

Jaguar I-Pace First Edition Photon Red
PGhiron is offline  
post #6 of 58 (permalink) Old 02-03-2019, 01:22 AM
Senior Member
 
jsimon7777's Avatar
 
Join Date: Jun 2018
Location: Castro Valley, CA
Posts: 737
Are you in dynamic or comfort mode? There is a big difference. The ride is much tauter than an X5 with far better handling. The X5 is a bit of a barge. Raising the suspension should improve the ride but hurt the handling. I haven't looked at the suspension to see how it senses height, but on my Ram, you can adjust the height by replacing some simple plastic parts connected to sensors. Swapping to 20s or 18s will make a difference in your ride. That's why we didn't get the 22s. That and all the potholes that would destroy 22s.

As for bugs in the infotainment, I don't find them important. Android Auto is crap on every car. I'd rather just use my phone when I need to. I also lived with a mid-early version of idrive. That was pretty miserable.
jsimon7777 is online now  
post #7 of 58 (permalink) Old 02-03-2019, 01:58 AM
Senior Member
 
sciencegeek's Avatar
 
Join Date: Jun 2018
Location: Palo Alto
Posts: 1,115
Quote:
Originally Posted by jsimon7777 View Post
As for bugs in the infotainment, I don't find them important. Android Auto is crap on every car. I'd rather just use my phone when I need to. I also lived with a mid-early version of idrive. That was pretty miserable.
The infotainment in my A3 etron (admittedly the cheapskate version without touchscreen) was straight from the stone ages. My expectations regarding infotainment are not super high so I refuse to let that ruin my enjoyment of the awesome car. That said, mine isn't all that bad .. the lag is a second here and there ... big deal. And I always let it boot up nicely before starting to drive. But others' experiences seem to be much worse .. surely not just user difference. Buggy PC comes to mind once again ...
bruintoo likes this.
sciencegeek is online now  
post #8 of 58 (permalink) Old 02-03-2019, 03:44 AM Thread Starter
Senior Member
 
Join Date: Dec 2018
Posts: 375
How long does yours take to boot? Mine seriously takes at least 90 seconds. I don't want to sit and wait for all my screens to pop up before hittings the road each time I get in the car.

I have driven in off-road mode several times. I didn't notice a huge difference. Also in the off-road mode, it won't automatically lower to access height - which is also a bit dumb. Our XC90 does that no matter what mode you're in.

My X5 definitely doesn't handle like a barge - but that's because I very specifically ordered it with the M-Diff and the other fancy suspension option - I can't remember the name. With those options and the offset 20" tires, the thing really handles quite well for its size. Don't get me wrong, it's nowhere near the handling of my 911 Turbo but it's not bad! Also, early I-Drive was horrendous. After that though, they really nailed it with the ease of functionality.

I was driving home tonight and the car forgot my settings for screen brightness and was blinding me while I tried to find the correct setting to lower the brightness again. I think it's the best in the business right now overall.

At the same time, the stupid heated windshield was making it hard for me to see anything with the blurry vision I get from it when cars are coming at me.

It was a blast to launch it when I got on the highway entry ramp and it's very nice and quiet at speed.

As I said, I'm very torn with what to think about it at this point and I really think if they had just nailed it with the infotainment system my experience wouldn't be quite so jaded.
sgtpeper is online now  
post #9 of 58 (permalink) Old 02-03-2019, 08:44 AM
Senior Member
 
Join Date: Dec 2018
Location: Norway
Posts: 139
I think you should reset everything you can in that car and start over, whether manually or with the push of some button. I dont know which one as I manually deleted all of my settings imaginable; profiles, bluetooth connections,sim cards, etc.
It worked wonders for me and things have been perfect since then.
phila is offline  
post #10 of 58 (permalink) Old 02-03-2019, 08:50 AM Thread Starter
Senior Member
 
Join Date: Dec 2018
Posts: 375
How long does it take for your car to boot now?

The other weird one is that sometimes my profile loads, sometimes it doesn't. Sometimes when I click on my profile it says I can't.

Always random.
sgtpeper is online now  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome