display panel not working at all - Jaguar I-Pace EV400 Forum
 10Likes
Reply
 
LinkBack Thread Tools
post #1 of 22 (permalink) Old 12-16-2018, 09:14 AM Thread Starter
Junior Member
 
Join Date: Dec 2018
Posts: 1
display panel not working at all

Hi
Can someone help
My I pace is fully charged but both the upper and lower display panels are not turning on when i am driving
thanks
LP
nini is offline  
post #2 of 22 (permalink) Old 12-16-2018, 11:26 AM
Senior Member
 
McRat's Avatar
 
Join Date: May 2018
Location: Norco, California, USA
Posts: 1,346
This seems to be the most common problem with new i-Paces.
My display stopped working, but I only had to shut down, remove USB stick, restart (fully), then reinstall stick and all was good.

Note that if you put it into Low Power mode from the MyEV screen#2, this deliberately blanks out the center console screen to save energy. But you'll see the battery saver icon on the lower right margin of the dash:
dtgsrq likes this.

Jaguar i-Pace FE Photon Red 20" wheels, "Leaper"
Two Chevrolet Volts in service
24.2 kW x 480v 3ph solar array self-installed.
McRat is online now  
post #3 of 22 (permalink) Old 12-17-2018, 06:30 PM
Junior Member
 
Join Date: Dec 2018
Posts: 3
Same issue - Mine has been in the shop since last Wednesday. Apparently there is a new software update, and they are waiting for Jag UK to confirm overnight if the new update they have provided is ok.

The dealer advised that they have now had 2 others in as well since mine came in.
navet42 is offline  
Sponsored Links
Advertisement
 
post #4 of 22 (permalink) Old 12-18-2018, 09:34 AM
Senior Member
 
Join Date: Dec 2018
Location: Norway
Posts: 139
Exact same situation here and happened more or less as soon as i left the dealer less then 1 week ago. A car like this really shouldn't have such buggy software, but it is what it is. I went back to the dealer after day 3 and they confirmed that there are many experiencing the same and a software fix is in the pipeline from Jaguar, lets hope before Christmas.
phila is offline  
post #5 of 22 (permalink) Old 12-18-2018, 10:45 AM
Senior Member
 
McRat's Avatar
 
Join Date: May 2018
Location: Norco, California, USA
Posts: 1,346
It's certainly an interesting situation. Computer code always behaves the same way at the same branches. All are 1/0.
So unless there is a hardware factor, or an external program that is locking up (cellphone O/S, wifi, etc), it is caused by some selection in the branch.

Many cars will exhibit strange behavior if the boot sequence is interrupted. For those who are concerned, try to activate the car with more delay time.
Hit the unlock button even if it's unlocked to start to wake it.
Push the brake down. Hold the ON/OFF button a full second minimum.
Get to the HOME screen, which is three boxes, R to L: Phone, Media, NAV.
Phone should be lit, wait for Media to wake up, then wait for NAV to wake up.
Now drive.
It can take up to 1 minute, or it can be instant. Not sure what the infotainment computer is looking for, but it is looking for something.
WattAJag likes this.

Jaguar i-Pace FE Photon Red 20" wheels, "Leaper"
Two Chevrolet Volts in service
24.2 kW x 480v 3ph solar array self-installed.
McRat is online now  
post #6 of 22 (permalink) Old 12-18-2018, 09:14 PM
Senior Member
 
PGhiron's Avatar
 
Join Date: Nov 2018
Location: Westchester, New York
Posts: 144
BTW I was looking through the menu structure and was somewhat dismayed to learn that you can ALSO blank the screen by assigning it to do to favorite button. That is a REALLY strange item to put on there as a possible choice. I sure hope that isn't what some people are having happen???
PGhiron is offline  
post #7 of 22 (permalink) Old 03-13-2019, 07:37 PM
Senior Member
 
Join Date: Feb 2019
Posts: 107
Wondering if anyone has an update on this or their experience? Our I-Pace was purchased brand new on 2/24 and on 3/8 the center stack screens (infotainment and climate) completely stopped working and the system turned the heat on and it could not be turned off. Back at the dealer now, they should be looking at it in the next few days.
billfan is offline  
post #8 of 22 (permalink) Old 03-13-2019, 08:29 PM
Member
 
squishball's Avatar
 
Join Date: Jan 2019
Location: San Francisco, CA
Posts: 65
Same issue a couple of weeks ago. Blank Infotainment and climate screens. Climate system running all the time. Incontrol app cannot connect to the I-Pace. Brought it into SF Jaguar, and they updated the IMC software. Once they did the update, all of the issues disappeared. Everything continues to functioning correctly.

I-Pace FE, Corris Gray, 20" rims
squishball is offline  
post #9 of 22 (permalink) Old 03-14-2019, 01:44 AM
Member
 
bguidizi's Avatar
 
Join Date: Dec 2018
Location: Southern California - Temecula area
Posts: 71
Quote:
Originally Posted by nini View Post
Hi
Can someone help
My I pace is fully charged but both the upper and lower display panels are not turning on when i am driving
thanks
LP
There are a few threads on this since it's a common issue many on the forums here before you experience this few lucky ones haven't. I have been in three times for this for software upgrades and the last time to have the telematics control unit replaced. Since they replace the TCU my screens have been solid not completely bug free but pretty solid and haven't turned off at all. Ask your local dealers if they have dealt with this. Call around to see if one has experience with the issue. The dealer I went to, went to school on my car, 1st to be serviced at their dealership.
bguidizi is offline  
post #10 of 22 (permalink) Old 03-14-2019, 10:15 PM
Junior Member
 
Join Date: Dec 2018
Location: Maui, Hi
Posts: 13
Aloha Billfan;
As I mentioned our I-pace was scheduled to return to Honolulu yesterday for the screen issues (2nd time in 1100 miles) and it missed the boat! Turns out on the way home with the car the screens lit back up and as of now all is working as normal. Waiting for a new sailing day to get the car back to the dealer so they can figure out what's going on. I'm starting to wonder if it might not be a connector that is loose as both times we have had these issues the screens returned to normal at some point and then blacked out again. I'll keep you updates.
Waltk is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Center Display Issues PGhiron Technical Discussion 67 01-06-2019 08:31 PM
Jaguar I-Pace Overview Administrator 2018+ Jaguar I-Pace EV 400 News 0 08-14-2018 05:50 PM
Dash Display Screens PinkJaguar 2018+ Jaguar I-Pace EV 400 General Discussion 9 03-24-2017 05:03 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome