Jaguar I-Pace EV400 Forum - View Single Post - My 1st & My LAST Jaguar
View Single Post
post #8 of (permalink) Old 05-14-2019, 09:32 PM Thread Starter
sflgator
Senior Member
 
sflgator's Avatar
 
Join Date: Sep 2018
Location: South Florida, USA
Posts: 175
Quote:
Originally Posted by gbillcb View Post
Probably shouldn't say this, but as I'm not superstitious, I will: I have had zero problems with my I Pace. Only a few thousand klicks so there's time yet, but so far everything is functioning perfectly. I don't even find the infotainment lag particularly problematic. (And it's much more fun to drive than my BMW 650ix Gran Coupe.)

Consider yourself lucky. Certainly surprised you haven't had any issues nor find the Infotainment system slow and buggy. My I-Pace absolutely has the latest software updates and the voice recognition for Navigation works 50% of the time at best and it's still super slow compared to other lux vehicles I've been in; it's just horrible. Then, I hop into my 2012 Nissan GT-R and the voice recognition for Navi and other controls work flawlessly for everything...and it's 7 years old! Oh, and of course none of our other cars have ever had any issues with the air conditioning. Glad you have a trouble-free I-Pace but as you said, there's still time, lol. I have > 8k on mine (although I would've had > 10k mi. already if not for all the issues and time it spends at my dealer).

2019 Jaguar I-Pace EV400 HSE
Indus Silver w/ Black Pack Ext & Front Fog Lights
Mars Red Windsor Leather Performance Seats w/ Carbon Fiber Trim,
Ebony Suede Headlining & Illuminated Jaguar Treadplates
22" Style 5069 Wheels
Adaptive Dynamics
sflgator is offline  
 
 
For the best viewing experience please update your browser to Google Chrome