Speedometer error - Jaguar I-Pace EV400 Forum
 2Likes
  • 1 Post By jsimon7777
  • 1 Post By WattAJag
 
LinkBack Thread Tools
post #1 of 9 (permalink) Old 04-25-2019, 09:23 PM Thread Starter
Member
 
Join Date: Nov 2018
Posts: 50
Speedometer error

Does anyone know whether the I Pace speedometer reads fast, like most ICE cars? My BMW was about 3 kms/hr fast - showed 100 when the actual speed was 97 kms/hr.
It would be useful to know!
gbillcb is online now  
post #2 of 9 (permalink) Old 04-25-2019, 10:10 PM
Senior Member
 
sciencegeek's Avatar
 
Join Date: Jun 2018
Location: Palo Alto
Posts: 902
I seem to remember that I tested that on my recent road trip to the desert and I think it was spot-on, maybe 1 mph fast.
sciencegeek is online now  
post #3 of 9 (permalink) Old 04-26-2019, 03:49 AM
Senior Member
 
Join Date: Apr 2019
Location: Fort Lauderdale
Posts: 148
This may not be available to the OP (citing km/hr means not in the US), but here at least, one could use the mile markers on the interstate for testing the calibration. Any speed could be used, but setting cruise control to a nominal 60 mph (or carefully manually maintaining it) and using a stop watch should yield 1 minute between them. (Otherwise: use slight math.)


Using dynamic mode gives access to the on-board lap stopwatch, for repeated mile segments, also. I don't know if accuracy at one speed means accurate at all speeds, but it probably does.

2019 I-Pace 400EV HSE First Edition
Corris Grey - Ebony/Ebony
Delivered 2/22/19
LauderdaleFE is online now  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 04-26-2019, 12:35 PM
Senior Member
 
Join Date: Nov 2018
Location: Central Florida
Posts: 260
Quote:
Originally Posted by gbillcb View Post
Does anyone know whether the I Pace speedometer reads fast, like most ICE cars? My BMW was about 3 kms/hr fast - showed 100 when the actual speed was 97 kms/hr.
It would be useful to know!
I've compared independent GPS speed readouts and the speedometer seems to read about right. If you have a portable GPS (Magellan, TomTom) that displays real-time speed, you can a quick check.

2019 I-Pace EV400 SE
Firenze Red - Ebony/Ebony
Driver Assist Pack
Black Exterior Pack
20" 5 Spoke Style 5068 Gloss Black Wheels
plus a few extras
Sbingham60 is offline  
post #5 of 9 (permalink) Old 04-26-2019, 01:15 PM Thread Starter
Member
 
Join Date: Nov 2018
Posts: 50
Yes, you're right Sbingham - I'll grab my Garmin from my truck and check - and report back.
gbillcb is online now  
post #6 of 9 (permalink) Old 04-26-2019, 02:00 PM
Senior Member
 
Join Date: Nov 2018
Location: Central Florida
Posts: 260
Quote:
Originally Posted by gbillcb View Post
Yes, you're right Sbingham - I'll grab my Garmin from my truck and check - and report back.
I think you might also need to check your tire settings to make sure it reflects what size you are running. I'm running 20", while many have 22". Not in front of my car for the navigation, but it's in the same menu where you check tire pressure and set load value.

2019 I-Pace EV400 SE
Firenze Red - Ebony/Ebony
Driver Assist Pack
Black Exterior Pack
20" 5 Spoke Style 5068 Gloss Black Wheels
plus a few extras
Sbingham60 is offline  
post #7 of 9 (permalink) Old 04-26-2019, 03:27 PM
Senior Member
 
Join Date: Jun 2018
Location: Castro Valley, CA
Posts: 604
Indicated speed matches the radar signs on our street within 1 mph.
gbillcb likes this.
jsimon7777 is online now  
post #8 of 9 (permalink) Old 04-26-2019, 04:25 PM
Senior Member
 
Join Date: Nov 2018
Location: Scottsdale, AZ
Posts: 336
Mine seems to be consistently indicating 1 MPH higher than I'm actually going - based on the radar/speed display signs near me. Also, interesting to note: If there is another car around me (even a little behind me) going a different speed, the signs seem to "see" them and not me. Or, if I'm approaching alone, they take a long time to recognize me. Makes me think that our cars might be a little bit naturally radar stealthy.
gbillcb likes this.
WattAJag is offline  
post #9 of 9 (permalink) Old 04-26-2019, 07:23 PM
Senior Member
 
Join Date: Nov 2018
Location: Central Florida
Posts: 260
Quote:
Originally Posted by Sbingham60 View Post
I think you might also need to check your tire settings to make sure it reflects what size you are running. I'm running 20", while many have 22". Not in front of my car for the navigation, but it's in the same menu where you check tire pressure and set load value.
I guess I didnt remember correctly. I dont see a spot to set the tire size. You can only set the load. Anyway looks like others are getting good speed based upon GPS readings. Good luck.

2019 I-Pace EV400 SE
Firenze Red - Ebony/Ebony
Driver Assist Pack
Black Exterior Pack
20" 5 Spoke Style 5068 Gloss Black Wheels
plus a few extras
Sbingham60 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Connection Error Jagpa Technical Discussion 6 03-04-2019 11:07 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome