ChargePoint Cable - Jaguar I-Pace EV400 Forum
 2Likes
  • 1 Post By StevenS
  • 1 Post By PS702
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 01-18-2020, 11:51 AM Thread Starter
Junior Member
 
Join Date: Jan 2020
Posts: 3
ChargePoint Cable

Recently purchased 2020 I Pace....installed Chargepoint system in my garage and the cable refused to go into the receptacle on the car. Jaguar blamed Chargepoint and Chargepoint blamed Jaguar. One tech from Chargepoint said they were aware of the problem along with same issue on VW. Tech said Chargepoint was redesigning the cable but would take 3-6 weeks. Chargepoint was very helpful and accommodating and sent a new system. I took out only the cable, plugged it in, and thankfully it worked like a charm.
One tech told me to "muscle" the original plug into the receptacle on the car, but I told him I didn't want to break anything. He said don't worry nothing would break. So I pushed it hard and at the same time pushed up and I finally heard the "click".
Deutsch100 likes this.
StevenS is offline  
post #2 of 3 (permalink) Old 01-18-2020, 12:29 PM
Senior Member
 
Join Date: Dec 2018
Location: Southwest, Florida USA
Posts: 477
I own a ChargePoint (Dec 2019) and have never had any issues connecting to my I-Pace (3 different ones, actually, including a loaner and replacement). However, I have visited several Level 2 and DCFC stations and had to "jam" the plug with uncomfortable force to get it to 'click'. Those rubber gaskets at the cable head surrounding the connectors can be VERY tight. No harm in "working them" to get a connection/click, IMHO.
dtgsrq is offline  
post #3 of 3 (permalink) Old 01-18-2020, 01:32 PM
Senior Member
 
PS702's Avatar
 
Join Date: Jul 2019
Posts: 438
I have the CP as well and it works like a charm.
I love everything about it


I had a Juicebox classic which was almost
impossible to remove from the receptacle and it had a very thick cord which made it very difficult to maneuver.
gbillcb likes this.

2019 HSE Ceasium Blue/oyster, 5068 wheels
April 2019 build date
Southern California, USA
PS702 is online now  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome