I'm so lost!! Please help - Jaguar I-Pace EV400 Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 07-06-2019, 04:45 PM Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 5
I'm so lost!! Please help

I ordered my 2019 HSE I-Pace last September after growing tired of my 4th gigantic Cadillac Escalade ESV. I saw the F-Pace, loved it, and was ready to downsize. Then I heard Jaguar was coming out with an electric I-Pace, and knew it would be worth the wait. I live in Northern Virginia - outskirts of Washington DC. We aren't that green (yet). It wasn't my plan to go green necessarily, and just days before picking up my new I-Pace, I was googling to find out what "EV" meant
I took ownership of my new car in March, and I LOVE my car! But she's not without her issues...
I've had to take her in for service twice within the first 2,000 miles because the front passenger door would not open from the inside.
* For the last 2-3 months the Remote Climate in the Jaguar remote app will not work. So I cannot start my car remotely. And it's super hot here in VA. Is there a fix for this?
* CarPlay works when it feels like it, but often not when I want it.
* My salesman was/is a super sweet guy, but when he entered me into the Jaguar system, he entered my email address incorrectly. And I think he knows about as much about the car as I do... So I get NO NEWS/E-MAILS from Jaguar. Do they send I-Pace related emails?
* Where do I go with my questions?
Does anyone have advice?
Hollyzworld is offline  
post #2 of 2 (permalink) Old 07-06-2019, 05:18 PM
Senior Member
 
Join Date: Oct 2018
Posts: 671
Hi there

First this place is a great source of info, read, ask.

Second have you gotten the dealer to apply all TSBs and update everything to latest?

Thats a good starting point.
epirali is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome